highnextCVE-2026-44574
Next.js has a Middleware / Proxy bypass through dynamic route parameter injection
Affected versions
>= 15.4.0, < 15.5.16, fixed in 15.5.16>= 16.0.0, < 16.2.5, fixed in 16.2.5
Published 2026-05-11. Last checked 2026-11-01. Read the source advisory