HoneyWarden
highnextGHSA-5j59-xgg2-r9c4

Next has a Denial of Service with Server Components - Incomplete Fix Follow-Up

Affected versions

  • >= 13.3.1-canary.0, < 14.2.35, fixed in 14.2.35
  • >= 15.0.6, < 15.0.7, fixed in 15.0.7
  • >= 15.1.10, < 15.1.11, fixed in 15.1.11
  • >= 15.2.7, < 15.2.8, fixed in 15.2.8
  • >= 15.3.7, < 15.3.8, fixed in 15.3.8
  • >= 15.4.9, < 15.4.10, fixed in 15.4.10
  • >= 15.5.8, < 15.5.9, fixed in 15.5.9
  • >= 15.6.0-canary.59, < 15.6.0-canary.60, fixed in 15.6.0-canary.60
  • >= 16.0.9, < 16.0.10, fixed in 16.0.10
  • >= 16.1.0-canary.17, < 16.1.0-canary.19, fixed in 16.1.0-canary.19

Published 2025-12-12. Last checked 2026-11-01. Read the source advisory

Scan your site for free